Monday, July 22, 2013

PfR Example #1




Elements

Our network above consists of 4 routers; R2 will act as the master controller as well as the border router
OSPF is running between R1, R2 and R4
We will depend only on throughput in making decisions; the bandwidth was manually set on the frame relay connection toward R3 in order to see the results faster as well as the holddown, periodic interval and monitoring period value
Two Traffic classes to be monitored R3 Lo0 and Lo1

Configuration

R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.1.12.1 255.255.255.0
 speed 100
 full-duplex
 no shut

router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.1.12.1 0.0.0.0 area 0

R2

ip cef

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet2/0
 ip address 192.1.12.2 255.255.255.0
 speed 100
 full-duplex
 no shut
!
interface Serial1/0
 bandwidth 256
 ip address 10.1.23.2 255.255.255.0
 encapsulation ppp
 no shut
!
interface FastEthernet2/1
 ip address 192.1.24.2 255.255.255.0
 speed 100
 full-duplex
 no shut
!
interface Serial1/1
 no ip address
 encapsulation frame-relay
 clock rate 128000
 no frame-relay inverse-arp
 no shut
!
interface Serial1/1.23 point-to-point
 bandwidth 128
 ip address 192.1.23.2 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 23  
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.1.12.2 0.0.0.0 area 0
 network 192.1.24.2 0.0.0.0 area 0
 default-information originate always

ip route 0.0.0.0 0.0.0.0 192.1.23.3
ip route 0.0.0.0 0.0.0.0 10.1.23.3 5

key chain KEY
 key 1
   key-string cisco

oer master
 !
 border 2.2.2.2 key-chain KEY
  interface Serial1/0 external
  interface Serial1/1.23 external
  interface FastEthernet2/0 internal
  interface FastEthernet2/1 internal
 !
 learn
  throughput
  periodic-interval 0
  monitor-period 1
 no max range receive
 holddown 90
 backoff 90 90
 mode route control
!
oer border
 local Loopback0
 master 2.2.2.2 key-chain KEY


R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255

interface Loopback1
 ip address 33.33.33.33 255.255.255.255

interface Serial1/0
 bandwidth 256
 ip address 10.1.23.3 255.255.255.0
 encapsulation ppp
 no shut

interface Serial1/1
 no ip address
 encapsulation frame-relay
 clock rate 128000
 no frame-relay inverse-arp
 no shut

interface Serial1/1.23 point-to-point
 bandwidth 128
 ip address 192.1.23.3 255.255.255.0
 snmp trap link-status
 frame-relay interface-dlci 32  

ip route 0.0.0.0 0.0.0.0 192.1.23.2

R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.1.24.4 255.255.255.0
 speed 100
 full-duplex
 no shut

router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 192.1.24.4 0.0.0.0 area 0

Verification

R2#show pfr master               
OER state: ENABLED and ACTIVE
  Conn Status: SUCCESS, PORT: 3949
  Version: 3.3
  Number of Border routers: 1
  Number of Exits: 2
  Number of monitored prefixes: 0 (max 5000)
  Max prefixes: total 5000 learn 2500
  Prefix count: total 0, learn 0, cfg 0
  PBR Requirements met
  Nbar Status: Inactive
  Auto Tunnel Mode: Off
 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:04:01          0  3.3
 
Global Settings:
  max-range-utilization percent 20 recv 0
  rsvp post-dial-delay 0 signaling-retries 1
  mode route metric bgp local-pref 5000
  mode route metric static tag 5000
  trace probe delay 1000
  logging
  exit holddown time 60 secs, time remaining 0
 
Default Policy Settings:
  backoff 90 90 90
  delay relative 50
  holddown 90
  periodic 0
  probe frequency 56
  number of jitter probe packets 100
  mode route control 
  mode monitor both
  loss relative 10
  jitter threshold 20
  mos threshold 3.60 percent 30
  unreachable relative 50
  trigger-log percentage 30
 
Learn Settings:
  current state : STARTED
  time remaining in current state : 91 seconds
  throughput
  no delay
  no inside bgp
  monitor-period 1
  periodic-interval 0
  aggregation-type prefix-length 24
  prefixes 100 appls 100
  expire after time 720
PfR versions have to match on both border and MC; if not equal MC should be higher
 
R2#show pfr master border 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:04:14          0  3.3
 
R2#show pfr master border detail 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:04:20          0  3.3
 Fa2/0           INTERNAL              UP             
 Fa2/1           INTERNAL              UP             
 Se1/1.23        EXTERNAL              UP             
 Se1/0           EXTERNAL              UP             
 
 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Se1/1.23        Tx       128         115         0       0 UP                    2
                      Rx                   128         0       0
 Se1/0            Tx      1544        1389         0       0 UP                    1
                      Rx                  1544         0       0
 
We will start ICMP traffic from R1 toward R3’s lo0 interface and 
ICMP traffic from R4 on its lo1 interface and check what will happen
 
R1#ping 3.3.3.3 source lo0 repeat 100000
Type escape sequence to abort.
 
R4#ping 33.33.33.33 source lo1 repeat 100000
 
R2#show pfr master border detail 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:01:48          0  3.3
 Fa2/0           INTERNAL              UP             
 Fa2/1           INTERNAL              UP             
 Se1/1.23        EXTERNAL              UP             
 Se1/0           EXTERNAL              UP             
 
 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Se1/1.23        Tx       128         115        13      10 UP                    2
                 Rx                   128        21      16
 Se1/0           Tx      1544        1389         0       0 UP                    1
                 Rx                  1544         0       0
 
*Jul 21 10:41:16.587: %PFR_MC-5-OOP_LINK: Load balance is out of policy.BR 2.2.2.2 i/f Se1/1.23 currently at %100 bandwidth utilization, BR 2.2.2.2 i/f Se1/0 currently at %0 bandwidth utilization
*Jul 21 10:41:16.591: %PFR_MC-5-OOP_LINK: The current bandwidth utilization of BR 2.2.2.2 intf Se1/1.23 is out of policy; Bandwidth untilization 128, configured threshold 115
*Jul 21 10:41:16.591: %PFR_MC-5-OOP_LINK: The load of 2.2.2.2 intf Se1/1.23 is out of policy. Transmit bandwith 128, Receive bandwidth 128,Transmit load 100, Receive Load 100
 
R2#show pfr master border detail 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:02:08          0  3.3
 Fa2/0           INTERNAL              UP             
 Fa2/1           INTERNAL              UP             
 Se1/1.23        EXTERNAL              UP             
 Se1/0           EXTERNAL              UP             
 
 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Se1/1.23        Tx       128         115       128     100 UP                    2
                 Rx                   128       128     100
 Se1/0           Tx      1544        1389         0       0 UP                    1
                 Rx                  1544         0       0
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.0/24             N    N    N           N           N N                 
                          DEFAULT*      @88           2.2.2.2 U               U       
 
3.3.3.0/24                N    N    N           N           N N                 
                          DEFAULT*      @88           2.2.2.2 U               U
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.0/24             N    N    N           N           N N                 
                          DEFAULT*      @57           2.2.2.2 Se1/1.23        U       
               U        U        0        0        0        0       92       92
               9        9        0        0        N        N        N        N
 
3.3.3.0/24                N    N    N           N           N N                 
                          DEFAULT*      @57           2.2.2.2 Se1/1.23        U       
               U        U        0        0        0        0       87       87
               1        1        0        0        N        N        N        N
 
 
*Jul 21 10:42:47.271: %PFR_MC-5-ROUTE_EVENT: 100% of traffic classes controlled through default policy are NOT INPOLICY (trigger-log-percentage is 30%)
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.0/24             N    N    N           N           N N                 
                          HOLDDOWN       27           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0      122      114
               U        U        0        0        N        N        N        N
 
3.3.3.0/24                N    N    N           N           N N                 
                          HOLDDOWN       30           2.2.2.2 Se1/1.23        STATIC  
               U        U        0        0        0        0      111      111
               2        2        0        0        N        N        N        N
 
R2#show pfr master border detail 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:05:09          0  3.3
 Fa2/0           INTERNAL              UP             
 Fa2/1           INTERNAL              UP             
 Se1/1.23        EXTERNAL              UP             
 Se1/0           EXTERNAL              UP             
 
 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Se1/1.23        Tx       128         115        95      74 UP                    2
                 Rx                   128       128     100
 Se1/0           Tx      1544        1389        94       6 UP                    1
                 Rx                  1544         0       0
 
R2#show pfr master traffic-class 
*Jul 21 10:44:36.763: %PFR_MC-5-OOP_LINK: Load balance is out of policy.BR 2.2.2.2 i/f Se1/1.23 currently at %73 bandwidth utilization, BR 2.2.2.2 i/f Se1/0 currently at %6 bandwidth utilization
*Jul 21 10:44:36.763: %PFR_MC-5-OOP_LINK: The load of 2.2.2.2 intf Se1/1.23 is out of policy. Transmit bandwith 94, Receive bandwidth 128,Transmit load 73, Receive Load 100
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.0/24             N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0      122      110
               U        U        0        0        N        N        N        N
 
3.3.3.0/24                N    N    N           N           N N                 
                          HOLDDOWN        2           2.2.2.2 Se1/1.23        STATIC  
               U        U        0        0        0        0      107      107
               2        2        0        0        N        N        N        N
 
R2#
*Jul 21 10:44:47.479: %PFR_MC-5-ROUTE_EVENT: 100% of traffic classes controlled through default policy are INPOLICY (trigger-log-percentage is 30%)
 
show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.0/24             N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0      122      106
               U        U        0        0        N        N        N        N
 
3.3.3.0/24                N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/1.23        STATIC  
               U        U        0        0        0        0      104      104
               2        2        0        0        N        N        N        N
 
What happened is that PfR moved one of the traffic streams to the higher BW link and kept the other one on the frame relay connection (Which we configured from the beginning as the default path for out traffic)
 
Now , after a while the traffic got back all to the frame relay connection , so what PfR did is moving both traffic streams to the serial connection 
*Jul 21 10:48:47.975: %PFR_MC-5-ROUTE_EVENT: 100% of traffic classes controlled through default policy are INPOLICY (trigger-log-percentage is 30%)
 
R2#show pfr master border detail 
Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
2.2.2.2          ACTIVE                UP       00:09:33          0  3.3
 Fa2/0           INTERNAL              UP             
 Fa2/1           INTERNAL              UP             
 Se1/1.23        EXTERNAL              UP             
 Se1/0           EXTERNAL              UP             
 
 External            Capacity      Max BW   BW Used    Load Status          Exit Id
 Interface            (kbps)       (kbps)    (kbps)    (%)                         
 ---------           --------      ------   ------- ------- ------           ------
 Se1/1.23        Tx       128         115         0       0 UP                    2
                 Rx                   128       128     100
 Se1/0           Tx      1544        1389       189      12 UP                    1
                 Rx                  1544         0       0
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.0/24             N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0        0       69
               U        U        0        0        N        N        N        N
 
3.3.3.0/24                N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0       91       90
               U        U        0        0        N        N        N        N
 
R2#show ip route static          
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
 
R2#show ip route static          
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
 
Gateway of last resort is 192.1.23.3 to network 0.0.0.0
 
S*    0.0.0.0/0 [1/0] via 192.1.23.3
      3.0.0.0/24 is subnetted, 1 subnets
S        3.3.3.0 [1/0] via 10.1.23.3, Serial1/0
      33.0.0.0/24 is subnetted, 1 subnets
S        33.33.33.0 [1/0] via 10.1.23.3, Serial1/0
 
As we can notice, the above static route we did not configure when we started
 
R2#show pfr master active-probes 
        OER Master Controller active-probes
Border   = Border Router running this Probe
State    = Un/Assigned to a Prefix
Prefix   = Probe is assigned to this Prefix
Type     = Probe Type
Target   = Target Address
TPort    = Target Port
How      = Was the probe Learned or Configured
N - Not applicable
 
The following Probes exist:
 
State      Prefix             Type     Target          TPort   How     Codec
Assigned   3.3.3.0/24         echo     3.3.3.3             N  Lrnd         N
Assigned   33.33.33.0/24      echo     33.33.33.33         N  Lrnd         N
 
The following Probes are running:
 
Border          State    Prefix             Type     Target          TPort
 
R2#show pfr master appl learned 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (packets-per-million), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
Prefix                Prot Port [src][dst]/ApplId        DSCP Source Prefix     
                          State     Time Curr BR         CurrI/F         Protocol
                        PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos
                        ActSDly  ActLDly   ActSUn   ActLUn      EBw      IBw
                        ActSJit  ActPMOS
-------------------------------------------------------------------------------------------
33.33.33.0/24                NA          NA              NA             
                       INPOLICY        0 2.2.2.2         Se1/0           STATIC  
                              U        U        0        0        0        0
                              U        U        0        0        0       72
                              N        N
3.3.3.0/24                   NA          NA              NA             
                       INPOLICY        0 2.2.2.2         Se1/0           STATIC  
                              U        U        0        0        0        0
                              U        U        0        0       90       72
 
R2#show pfr master traffic-class performance ip any 33.33.33.0/24 
==============================================================================================
 
Traffic-class:
 Destination Prefix : 33.33.33.0/24           Source Prefix    : N/A
 Destination Port   : N/A                     Source Port      : N/A
 DSCP               : N                       Protocol         : N/A
 Application Name:  : N/A
 
 General:
   Control State                   : Controlled using STATIC
   Traffic-class status            : INPOLICY
   Current Exit                    : BR 2.2.2.2 interface Se1/0, Tie breaker was load-balance criteria
   Time on current exit            : 0d 0:2:11
   Time remaining in current state : @76 seconds
   Last uncontrol reason           : Exit mismatch
   Time since last uncontrol       : 0d 0:3:40
   Traffic-class type              : Learned
   Improper config                 : None
 
 Last Out of Policy event:
   Exit                            : BR 2.2.2.2 interface Se1/0
   Reason                          : unreachable criteria
   Time since Out of Policy event  : 0d 0:0:13
   Active Unreachable Performance  : 0%
   Active Unreachable Threshold    : 50%
   Passive Unreachable Performance : 0%
   Passive Unreachable Threshold   : 50%
 
 Average Passive Performance Current Exit: (Average for last 5 minutes)
   Unreachable            : 0% -- Threshold: 50%
   Delay                  : 0% -- Threshold: 50%
   Loss                   : 0% -- Threshold: 10%
   Egress BW              : 0 kbps
   Ingress BW             : 58 kbps
   Time since last update : 0d 0:0:13
 
 Average Active Performance Current Exit: (Average for last 5 minutes)
   Unreachable            : 0% -- Threshold: 50%
   Delay                  : 0% -- Threshold: 50%
 
 Last Resolver Decision:
   BR              Interface    Status       Reason       Performance Threshold
   --------------- ------------ ------------ ------------ ----------- ---------
   2.2.2.2         Se1/1.23     Eliminated   Utilization  Unknown      Unknown     
   2.2.2.2         Se1/0        Best Exit    Range        N/A          N/A         
 
R2#show pfr master traffic-class performance ip any 3.3.3.0/24    
==============================================================================================
 
Traffic-class:
 Destination Prefix : 3.3.3.0/24              Source Prefix    : N/A
 Destination Port   : N/A                     Source Port      : N/A
 DSCP               : N                       Protocol         : N/A
 Application Name:  : N/A
 
 General:
   Control State                   : Controlled using STATIC
   Traffic-class status            : INPOLICY
   Current Exit                    : BR 2.2.2.2 interface Se1/0, Tie breaker was load-balance criteria
   Time on current exit            : 0d 0:2:0
   Time remaining in current state : 0 seconds
   Last uncontrol reason           : Exit mismatch
   Time since last uncontrol       : 0d 0:3:30
   Traffic-class type              : Learned
   Improper config                 : None
 
 Last Out of Policy event:
   Exit                            : BR 2.2.2.2 interface Se1/0
   Reason                          : load-balance criteria
   Time since Out of Policy event  : 0d 0:2:6
   Link OOP; no prefix performance :
 
 Average Passive Performance Current Exit: (Average for last 5 minutes)
   Unreachable            : 0% -- Threshold: 50%
   Delay                  : 0% -- Threshold: 50%
   Loss                   : 0% -- Threshold: 10%
   Egress BW              : 0 kbps
   Ingress BW             : 56 kbps
   Time since last update : 0d 0:0:33
 
 Average Active Performance Current Exit: (Average for last 5 minutes)
   Unreachable            : 0% -- Threshold: 50%
   Delay                  : 0% -- Threshold: 50%
 
 Last Resolver Decision:
   BR              Interface    Status       Reason       Performance Threshold
   --------------- ------------ ------------ ------------ ----------- ---------
   2.2.2.2         Se1/1.23     Eliminated   Range        80%          10%         
   2.2.2.2         Se1/0        Best Exit    Range        N/A          N/A         
 
R2#show pfr master traffic-class learned throughput 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
3.3.3.0/24                N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0        0       56
               U        U        0        0        N        N        N        N
 
33.33.33.0/24             N    N    N           N           N N                 
                          INPOLICY      @24           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0        0       71
               4        4        0        0        N        N        N        N
 
 
Now, both loopbacks on R3 are configured with /32 mask, so we want to learn these prefixes with their respective mask
 
R2
 
pfr master 
learn 
aggregation-type prefix-length 32
 
R2#clear pfr master *
 
And let us start the ICMP traffic patterns again
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.33/32            N    N    N           N           N N                 
                          DEFAULT*      @66           2.2.2.2 U               U       
 
3.3.3.3/32                N    N    N           N           N N                 
                          DEFAULT*      @66           2.2.2.2 U               U       
 
 
 
*Jul 21 11:37:08.687: %PFR_MC-6-ROUTE_EVENT_INFO: Discovered exit BR 2.2.2.2, i/f Se1/1.23 for traffic class Prefix 3.3.3.3/32 
*Jul 21 11:37:08.687: %PFR_MC-6-ROUTE_EVENT_INFO: Discovered exit BR 2.2.2.2, i/f Se1/1.23 for traffic class Prefix 33.33.33.33/32 
*Jul 21 11:37:12.115: %PFR_MC-5-OOP_LINK: Load balance is out of policy.BR 2.2.2.2 i/f Se1/1.23 currently at %100 bandwidth utilization, BR 2.2.2.2 i/f Se1/0 currently at %0 bandwidth utilization
*Jul 21 11:37:12.115: %PFR_MC-5-OOP_LINK: The current bandwidth utilization of BR 2.2.2.2 intf Se1/1.23 is out of policy; Bandwidth untilization 128, configured threshold 115
*Jul 21 11:37:12.115: %PFR_MC-5-OOP_LINK: The load of 2.2.2.2 intf Se1/1.23 is out of policy. Transmit bandwith 128, Receive bandwidth 128,Transmit load 100, Receive Load 100
*Jul 21 11:38:11.859: %PFR_MC-6-ROUTE_EVENT_INFO: Prefix 3.3.3.3/32: route changed to BR 2.2.2.2, i/f Se1/0, due to load-balance criteria. Out of policy reason: utilization criteria
*Jul 21 11:38:11.875: %PFR_MC-6-ROUTE_EVENT_INFO: Prefix 33.33.33.33/32: route changed to BR 2.2.2.2, i/f Se1/0, due to load-balance criteria. Out of policy reason: utilization criteria
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.33/32            N    N    N           N           N N                 
                          HOLDDOWN       68           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0       71       71
               U        U        0        0        N        N        N        N
 
3.3.3.3/32                N    N    N           N           N N                 
                          HOLDDOWN       67           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0       73       73
               U        U        0        0        N        N        N        N
 
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
33.33.33.33/32            N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0       71       66
               U        U        0        0        N        N        N        N
 
3.3.3.3/32                N    N    N           N           N N                 
                          INPOLICY        0           2.2.2.2 Se1/0           STATIC  
               U        U        0        0        0        0       73       66
               U        U        0        0        N        N        N        N
 
Suppose that we are in concern of one prefix only, we can filter the prefixes learned through what so called learn list , let us assume we want to monitor only 3.3.3.0/24 prefix
 
ip prefix-list PREFIX1 seq 5 permit 3.3.3.3/32
 
ip access-list extended ICMP
permit icmp any any
 
ip access-list extended DENY_GLOBAL
 deny ip any any
 
pfr master 
learn
  traffic-class filter access-list DENY_GLOBAL
list seq 5 refname R3LOOP0
traffic-class access-list ICMP filter PREFIX1
throughput
 
Then we should configure a pfr-map that will match the learn list we configured above and apply it to the pfr master
 
pfr-map MAP 10
 match pfr learn list R3LOOP0
 
pfr master
 policy-rules MAP
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
3.3.3.0/24                N    N    1           N           N 0.0.0.0/0         
                          DEFAULT*      @49           2.2.2.2 U               U  
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
3.3.3.0/24                N    N    1           N           N 0.0.0.0/0         
                          HOLDDOWN       81           2.2.2.2 Se1/0           PBR     
               U        U        0        0        0        0       15       15
               U        U        0        0        N        N        N        N
 
R2#show pfr master traffic-class 
OER Prefix Statistics:
 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
 P - Percentage below threshold, Jit - Jitter (ms), 
 MOS - Mean Opinion Score
 Los - Packet Loss (percent/10000), Un - Unreachable (flows-per-million),
 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
 # - Prefix monitor mode is Special, & - Blackholed Prefix
 % - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix           Appl_ID Dscp Prot     SrcPort     DstPort SrcPrefix         
           Flags             State     Time            CurrBR  CurrI/F Protocol
         PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos      EBw      IBw
         ActSDly  ActLDly   ActSUn   ActLUn  ActSJit  ActPMOS  ActSLos  ActLLos
--------------------------------------------------------------------------------
3.3.3.0/24                N    N    1           N           N 0.0.0.0/0         
                          INPOLICY        0           2.2.2.2 Se1/0           PBR     
               U        U        0        0        0        0        0       37
               U        U        0        0        N        N        N        N
 
R2#show pfr master learn list 
 
 Learn-List seq 5 refname R3LOOP0
   Configuration:
    Traffic-Class Access-list: ICMP
    Filter: PREFIX1
    Aggregation-type: prefix-length 24
    Learn type: throughput
    Session count: 1000 Max count: 1000
    Policies assigned: 10
    Status: ACTIVE
   Stats:
    Traffic-Class Count: 1
    Traffic-Class Learned:
     Appl Prefix 3.3.3.0/24 N    1
 

No comments: